Identity Platform Outage 10/31/23
Incident Report for Intellicheck
Resolved
Services have been restored and are functioning properly.
Posted Oct 31, 2023 - 15:00 EDT
Monitoring
A correct has been put in place and we are monitoring the results.
Posted Oct 31, 2023 - 14:39 EDT
Investigating
We are currently investigating an issue with the Identity Platform impacting Portal+ and Platform API customers. We will update as soon as the issue is resolved.
Posted Oct 31, 2023 - 13:46 EDT
This incident affected: Intellicheck Digital Identity Platform (Intellicheck Identity Platform, ID Verification Services, Facial Services, OFAC & Sanction Screening Services, Criminal Data Services, Device Fingerprint & Fraud Detection Services, Identity Platform Hosted Services) and IDN Portal+.