Performance Degradation of Device Fingerprint & Fraud Detection Services
Incident Report for Intellicheck
Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 12:22 EDT
Investigating
We are currently experiencing long response times from our Device Fingerprint & Fraud Detection Services.
We are working with our partners to quickly mitigate the issue.

We will continue to update this alert as soon as possible.
Posted Apr 04, 2023 - 11:01 EDT
This incident affected: Intellicheck Digital Identity Platform (Device Fingerprint & Fraud Detection Services).