Intellicheck Degradation of Services
Incident Report for Intellicheck
Resolved
Intellicheck services have been restored. We continue to investigate cause.
Posted Jul 22, 2023 - 14:24 EDT
Investigating
Intellicheck is currently investigating an issue that is negatively impacting our services.
Posted Jul 22, 2023 - 14:17 EDT
This incident affected: IDN-Direct Services (IDN-Direct Online Services, IDN-Direct ProcessPhoto, IDN-Direct - ProcessID), Intellicheck Digital Identity Platform (Intellicheck Identity Platform, ID Verification Services), and IDN Portal+.