SMS text message delivery issues to Canada
Incident Report for Intellicheck
Resolved
This incident has been resolved.
Posted Sep 12, 2023 - 16:57 EDT
Update
We are continuing to investigate this issue.
Posted Sep 12, 2023 - 16:57 EDT
Update
The issue has been resolved. Should you experience any issues, please contact support-ticket@intellicheck.com
Posted Sep 12, 2023 - 16:56 EDT
Update
Intellicheck Engineering has redirected SMS traffic so those customers affected. Messages are being delivered.
Should you continue to experience issues, please notify our staff at support-ticket@intellicheck.com
Posted Sep 12, 2023 - 15:25 EDT
Investigating
We are currently investigating an issue where SMS text messages to mobile phone numbers in Canada are either delayed or undelivered.
We will update our status shortly.
Posted Sep 12, 2023 - 13:30 EDT
This incident affected: IDN Portal+ and Intellicheck Digital Identity Platform (Identity Platform Hosted Services).