SMS Degradation when sending to Verizon
Incident Report for Intellicheck
Resolved
SMS Texts to US/CA Verizon are operational.
Posted Apr 04, 2023 - 18:00 EDT
Investigating
Our SMS Texting vendor is experiencing quality degradation toward US/CA Verizon Wireless. Customers that send SMS messages to Verizon Wireless users may notice a difficulties in message delivery.
Posted Apr 04, 2023 - 16:13 EDT
This incident affected: Intellicheck Digital Identity Platform (Intellicheck Identity Platform) and IDN Portal+.