Intermittent outages impacting all services
Incident Report for Intellicheck
Resolved
Services appear to have been restored as of 11:51 AM ET. We are continuing to monitor.
Posted Oct 10, 2023 - 12:21 EDT
Update
We are continuing to investigate this issue.
Posted Oct 10, 2023 - 11:48 EDT
Investigating
Starting at approximately 11:00 AM ET Intelliecheck began receiving alerts about potential outages impacting multiple services. Current investigations appear to point to a suspected cloud service provider outage. We are working to stabilize services.
Posted Oct 10, 2023 - 11:48 EDT
This incident affected: IDN-Direct Services (IDN-Direct Online Services, IDN-Direct ProcessPhoto, IDN-Direct - ProcessID, IDN-Direct - ID Verification Services for POS), Intellicheck Digital Identity Platform (Intellicheck Identity Platform, ID Verification Services, Facial Services, OFAC & Sanction Screening Services, Criminal Data Services, Device Fingerprint & Fraud Detection Services, Identity Platform Hosted Services), IDN Portal (Intellicheck Mobile Services), and IDN Portal+.