Service degradation, Facial Services
Incident Report for Intellicheck
Resolved
The issue has been resolved and full service has been restored.
Posted Jun 21, 2023 - 12:55 EDT
Identified
Intellicheck engineers have identified the problem and are in the process of deploying a corrective fix.
Posted Jun 21, 2023 - 11:59 EDT
Investigating
We are currently experiencing issues with our facial matching services. The issue is being investigated.
Posted Jun 21, 2023 - 10:27 EDT
This incident affected: IDN Portal+ and Intellicheck Digital Identity Platform (Facial Services).